Error 270: The security library could not be loaded

When I attempt to run your SSL controls on my Windows 9x machine, I get an error, "Error 270: The security library could not be loaded".

Date Entered: 11/1/2001    Last Updated: 11/1/2001

IPWorks SSL makes use of the security libraries that come installed with Windows NT 4.0 SP4+ and Windows 2000. There is an option in IPWorks SSL to enable the use of Wininet, provided with Microsoft Internet Explorer Version 3.0 or higher). While this will not allow you to use all of the secure components, it will allow you to use the HTTPS control.

In order to use the other SSL components in Win9x platforms or to avoid using wininet, You have to enable SSPI in order to make it run on Windows 9x platforms.

Here is a quick description of the instructions that you need to follow.

1. Get the latest build of IPWorks SSL. You can get this from https://www.nsoftware.com/download/.

2. Internet Explorer 5.5 must be installed on to the Windows 95 or Windows 98 system.

3. You must install the DSCLIENT.EXE file that can be found on the windows 2000 server CD. You can find this file at: \Clients\Win9x\DSCLIENT.EXE. This updates several important pieces of the security subsystem.

4. The Registry must be updated. You need to add ", schannel.dll" to the end of the string found in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders. For those of you new to editing the registry you can run regedit to modify the registry.

>

We appreciate your feedback.  If you have any questions, comments, or suggestions about this entry please contact our support team at kb@nsoftware.com.